BTHS National Honor Society - High Latency – Incident details

All systems operational

High Latency

Resolved
Degraded performance
Started over 3 years agoLasted about 1 month

Affected

API

Degraded performance from 6:18 PM to 10:29 PM

Website

Degraded performance from 6:18 PM to 10:29 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Cloudflare datacenter upgrades are complete. We are now currently monitoring the result.

  • Identified
    Identified

    Cloudflare is performing data center and network upgrades, causing high latency across our network.

  • Investigating
    Investigating

    Signing into accounts results in a network timeout and subsequent failure. We're investigating this issue.