BTHS National Honor Society - Unable to access website – Incident details

All systems operational

Unable to access website

Resolved
Under maintenance
Started almost 3 years agoLasted 16 minutes

Affected

Website

Under maintenance from 4:10 AM to 4:26 AM

Updates
  • Resolved
    Resolved

    Update complete. The website is now accessible.

  • Identified
    Identified

    We are currently blocking access to the website while we make an urgent technical update. Thank you for your patience.